Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Install ES9028/9018 DAC driver into Volumio
#1
As we know, the boards based on the ES9028\9018 chips work fine with the driver of the I-Sabre 9028k2m audio driver in the DietPi, but the official audio plugin for these boards does not work in Volumio. This is because when the driver is turned on in the DietPi, driver sources are downloaded and builded in accordance with the source code of the kernel, so all we need is to do the same in Volumio.  
So...

1. Login into Volumio through the command line under the root user:

Code:
login: root 
password: volumio

2. Download necessary tools:

Code:
apt-get install python build-essential git device-tree-compiler gcc-4.9 g++-4.9

3. after these we need download Volumio kernel sources:

Code:
volumio kernelsource

4. Rename source files folder:

Code:
mv /lib/modules/4.9.80+/build /lib/modules/4.9.80+/source

5. Download driver source

Code:
git clone https://github.com/SatoruKawase/I-Sabre-K2M

6. Enter in driver source folder:

Code:
cd I-Sabre-K2M

7. Build kernel modules:

Code:
make

8. Install kernel modules

Code:
make modules_install

9. Rename source files folder again:

Code:
mv /lib/modules/4.9.80+/source /lib/modules/4.9.80+/build

10. Build driver:

Code:
make dtbs

11. Install driver:

Code:
make install_dtbo

12. If all it's OK open Volumio config.txt:

Code:
sudo nano /boot/config.txt

and add folowing string:

Code:
dtoverlay=i-sabre-k2m

13. Reboot device:

Code:
sudo reboot

14. Check driver installation: 

Code:
aplay -L

if you see these


Code:
default:CARD=DAC
    I-Sabre K2M DAC

    Default Audio Device


it's mean what all is OK
Enter into Volumio web GUI and choose I-Sabre ES9028 DAC in sound perferences, If needed reboot device and...

Enjoy!)
Reply
#2
heavy !!
thats what/for i searched over half a year, as i had these ES9028Q2M and don´t know how to really include the original "Sabre-driver";
all what i/we had were these "hifiberry-dac" "compability-mode" Smile  ..
("normal" ES9028Q2M hadnt worked for me in Dietpi with the i-sabre-k2m driver !!)

Had at this time a lot of e-mail/github contact with "fourdee" at DietPi if he had a special driver/.dtbo for the ES9028Q2M..

I guess a tricky user can include it , with the help of this post, also in Dietpi and then we have the 384khz again (and with the sabre-driver !!)!!!
(and also for "normal"/not Audiophonics ES9028Q2Ms)

would be soo nice..i could maybe check it out the days how to do it (.dtbo, include in Dietpi or other (Moode or something)..)

so many thx again !! (and stay "tuned")   Cool
Reply
#3
(04-05-2018, 20:55 PM)admin Wrote: heavy !!
thats what/for i searched over half a year, as i had these ES9028Q2M and don´t know how to really include the original "Sabre-driver";
all what i/we had were these "hifiberry-dac" "compability-mode" Smile  ..
("normal" ES9028Q2M hadnt worked for me in Dietpi with the i-sabre-k2m driver !!)

Had at this time a lot of e-mail/github contact with "fourdee" at DietPi if he had a special driver/.dtbo for the ES9028Q2M..

I guess a tricky user can include it , with the help of this post, also in Dietpi and then we have the 384khz again (and with the sabre-driver !!)!!!
(and also for "normal"/not Audiophonics ES9028Q2Ms)

would be soo nice..i could maybe check it out the days how to do it (.dtbo, include in Dietpi or other (Moode or something)..)

so many thx again !! (and stay "tuned")   Cool
I am very glad that I could help everyone who uses ES9028/9018 chip-based boards in their projects Smile
Latest versions of DietPi (and other Raspbian-based distros) used .dtbs drivers instead .dtbo and not needed to port this driver into DietPi, you can just enable I-Sabre ES9028K2M DAC in dietpi-config and this should work.
If you want to use my thread in Moode or other distros you can use this instructions: https://github.com/SatoruKawase/I-Sabre-...INSTALL.md
Reply
#4
Nice !! (and also the other "headphone"-topic)

and post,post,post !!  Smile
Reply
#5
I intalled K2M driver successfully. However, I cannot neither airplay from an IOS device nor play ALAC files from my library. In both cases I can hear distorted sound in the right channel only.

I am using RPI3b+ with ES9038q2m and my blue board lits both DSD and Lock. Does anyone have a solution for that?



[Image: 8-D9-FC6-B9-A99-F-402-A-B9-B4-0-B9-D8-BD84-CC9.jpg]
Reply
#6
which audio-distro do u use ?
volumio ? 
choose another card/-settings."Allo Katana" or something else.."generic-i2s" and so on..
thx and greets
Reply
#7
(02-13-2019, 11:39 AM)admin Wrote: which audio-distro do u use ?
volumio ? 
choose another card/-settings."Allo Katana" or something else.."generic-i2s" and so on..
thx and greets

Yes, I use volumio. 
I started with "generic-i2s" and it was exactly the same. Actually, I though that installing the K2M driver I will fixed the problem.

Did you experience similar issue?
Reply
#8
yes,
i (we) had this "...distorted sound in the right channel only." also a few months ago..
but it is too far away (time) i cant remember the exact circumstances, distro, DSD or not and so on..
please try to read/find more articles/posts here on essabre-90xx (+comments) i think in some place there was a solution/answer..
 but many thx + keep asking/posting !!  Smile Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)